Go Back   Bream Master Forums > Bream Boats > Electric Trolling Motors

Electric Trolling Motors The ultimate bream fishing accessory...



Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-06-2018, 02:07 AM
CK's Avatar
CK CK is offline
Blue Lip
 
Join Date: Jan 2006
Location: ADELAIDE
Posts: 1,482
Motorguide W55 Wireless

Is there any help from the brains trust here regarding some difficulties I'm having with my Leccie?
Running off a 120A/H gel battery, when the usage gets below 13A the motor begins to play up n not function properly.
Symptoms include poor performance, lack of control, and total disconnect requiring the power to require bumping up again from its previous setting when turned off. (if that last bit makes sense). It's basically all the drama's of severely low battery.
I've never had one of these apart before but reckon it cant be too hard.
I'd happily take it to a service professional if there were one here in Adelaide, but investigations there have drawn a blank.
I've checked n cleaned the battery connections and the battery indicator on the motor is saying that the batteries charge is still good when these symptoms arise. Whilst I don't have a dedicated multimeter, connecting up to the charger at the end of the day shows how much power was used from the battery, hence the knowledge on where the problems begin.
__________________
Proudly Supported by;
Hyper Tackle - Zipbaits



PB Bream - Bait 42cm
PB Bream - SP 52cm
PB Bream - HB 44cm

Its a work in progress
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -4. The time now is 03:22 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Google